deprecate icu-config?

Description

http://userguide.icu-project.org/howtouseicu (as of right now) deemphasizes icu-config over pkg-config. Consider deprecating icu-config, maybe making it a thin wrapper that just calls pkg-config

Activity

Show:
TracBot
June 30, 2018, 11:48 PM
Trac Comment 5 by —2014-09-24T22:53:09.777Z

Roll

Steven R. Loomis
July 24, 2018, 10:50 PM

See icu-10464 for some background text

Hugh McMaster
October 5, 2018, 7:53 AM

I noticed the optional installation status of ‘icu-config’ is not mentioned in the release notes for 63.1-RC. Is this an oversight?

Steven R. Loomis
October 24, 2018, 6:01 PM

I will update the userguide and the download page.

Steven R. Loomis
October 24, 2018, 6:33 PM
Edited

For the record, as of ICU 63.1 you can use {{ --disable-icu-config }} to disable icu-config, or {{ --enable-icu-config }} to enable it (which is the default). If you need icu-config, please start using {{ --enable-icu-config }} so that we can change the default to 'disable' in the future.

(Using --enable-icu-config on releases prior to 63.1 is safe, it only produces a warning about an unrecognized option.)

See http://userguide.icu-project.org/howtouseicu for more details on how to use ICU without using icu-config.

Fixed

Assignee

Steven R. Loomis

Reporter

Steven R. Loomis

Components

Labels

None

Reviewer

None

Priority

major

Time Needed

None

Fix versions

Configure