We're updating the issue view to help you get more done. 

Document Binary Compatibility

Description

Document the policies on binary compatibility more clearly, that:

  • ICU C and Java API that is marked stable in 3.0 is binary compatible from 3.0
    forward.

  • We provide a way to let people check whether they are using only stable API in
    ICU4C 3.0 and later; and document that method clearly (In 3.2 we will provide a
    way to let people check in Java.)

  • We make no promises for non-stable API, or API before 3.0.

Status

Assignee

Andy Heninger

Reporter

TracBot

Labels

Reviewer

None

Time Needed

None

Start date

None

Components

Fix versions

Priority

critical