I noticed two things when I added time bombs a couple of days ago:
1. In Java, skipIfBeforeICU() is misnamed. The name says "before" but it tests "before or equal". See http://bugs.icu-project.org/trac/changeset/28656#file1
2. In C, the corresponding function is called isICUVersionAtLeast(). It would be nice if we had the same names in both C & J. Also, the C version is harder to use because it takes a UVersionInfo, and it would be more convenient if it took 3 ints instead for a simpler call site like in Java.
I plan to change these (and their current call sites) in both C & J to isICUVersionBefore(major, minor, milli) and isICUVersionAtLeast(major, minor, milli).