Improve specs around inverse unit handling

Description

https://www.unicode.org/reports/tr35/tr35-info.html#Unit_Conversion currently has only one paragraph about inverse handling. This paragraph needs improvement, and the specification of inverse fleshed out. The sentence on the inverse:

"The quantity for a complex unit that has a reciprocal is formed by prepending “inverse-” to the quantity, such as inverse-consumption."

  • Currently unitPreferenceData in https://github.com/unicode-org/cldr/blob/master/common/supplemental/units.xml has "consumption-inverse" usages, not "inverse-consumption".

  • How this data is to be used is not clear. Both "consumption" and "consumption-inverse" have regions="001" entries, meaning default fallbacks.

  • Should there be only one entry (only "consumption", and not "consumption inverse")?

  • Or should these two be treated as a merged entry automatically, which would mean priority for the 001 region needs to be established?

  • If we want this tweakable, API's using this data might need an "enable inverse" and "disable inverse" option, then the fallback is useful (but precedence needs to be clear for "enable inverse").

xpath

None

locale

None

Priority

TBD

Assignee

Unassigned

Reporter

Hugo van der Merwe

Reviewer

None

Labels

None

Components

Fix versions

phase

None
Configure