I've seen the most usage of these terms in /filters/*. One possibility is changing these to allowlist/blocklist.
I have seen: safelist or allowlist vs blocklist or denylist
Those are good. Also includelist or excludelist work too.
Given the existing usage (or existing filter files) we’d likely need to add aliases for the existing terms as well.
For data filtering, “include”/”exclude” without the “list” suffix might work and be clear.
We also have “whitelist”/”blacklist” in the spoof checker API docs (both C++ and Java).
https://developers.google.com/style/inclusive-documentation#features-and-users “Avoid using socially-charged terms for technical concepts where possible. For example, avoid terms such as blacklist, native feature, and first-class citizen, even though these terms may still be widely used. Instead of first-class, consider other terms such as: core feature, built-in, top-level. Choose the best term for your context.“